Radio Upgrade Time

03cobra#2

Hobbyist Of Many Hobbies
Established Member
Joined
Feb 9, 2007
Messages
1,543
Location
Cleveland, Ohio
ad some time to play around with the system for a while. The J2Fab 270 alternator, and XS3400 battery have made a big difference. Most music plays pretty well with very little voltage drop. One thing I did notice is on strong, quick bass hits there is still pretty good voltage drop. Doing a bit of research it seems and additional battery in the trunk by the amps will still be needed. The Alternator can not supply the current demand quickly enough, because alternators are slower to react on demands from the amplifiers.....so the extra amp hours of batteries are needed (quick release of energy for quick precise bass notes, like kick drums ect.). With longer continuous bass hits I see voltage in the 14's which is saying my alternator is supplying enough current.

Looks like I'll be adding a 5-6lb lithium battery in the trunk and I should have all my electrical demands covered.

Driving around with extra weight is not too noticeable. On the days I want to get out there and goof around on the street I'll pull the subs out, but other then that the whole package of speed and sound is really fun!
 

03cobra#2

Hobbyist Of Many Hobbies
Established Member
Joined
Feb 9, 2007
Messages
1,543
Location
Cleveland, Ohio
All finished up. I installed a 22ah battery, and battery isolator. Reason for the isolator is the resting voltage of the battery up front is roughly 12.5, and the lithium is 13.5 or so. To prevent the agm battery from leeching off the lithium the isolator disconnects the lithium from the circuit while the car is off then reconnects when the key is on.

Couple things I noticed. The car sure starts quicker now lol. Playing music at full tilt, heavy bass music, test tines ect the voltage didn't drop below 13.5-13.7, amd that's at idle. I hammered on it for about 10-15 minutes and the amp did not shut off or get hot. In fact it only got slightly ward. I set my hand on the dust caps of the subs amd they were warmer then the amp.

Now that everything is in and done, I still may take the car to a shop and have them professionally tune the system, not sure yet.

Once the weather gets a bit better I'll take the car out and do some wot pulls, because I'm interested to see how the J2fab alternator holds up. Cold idle voltage is 15-15.2. Warmed up its 14.8 or so. Hopefully under load it stay above 14 like my kmj did.
 

Users who are viewing this thread



Top