• Welcome to SVTPerformance!
ATTENTION!
You may experience intermittent issues while accessing the site over the next 60-90 minutes, as we perform maintenance and upgrades.

Lifter/rocker noise...

Discussion in '2013-14 Shelby GT500' started by Devious_Snake, Feb 26, 2014.

  1. Devious_Snake

    Devious_Snake PSR Major! Established Member

    Messages:
    9,980
    Joined:
    Dec 25, 2011
    Location:
    Hell
    I found a thread on Fordgt500 with a guy who described a noise that I have. I am almost certain its a lifter/rocker thats not sitting right. I can hear the ticking around 1100-2K rpms. It goes away off throttle and you can hear the ticking rattling on throttle. Seems like something I can tackle myself by pulling the valve covers off and checking. So my question, what should I go with for replacement, costs, etc? How easy of a job is it? Experience with it? thanks


    Vendors by all means chime in too
     
  2. BadSonicBlueSVT

    BadSonicBlueSVT Member Established Member

    Messages:
    267
    Joined:
    Feb 23, 2012
    Location:
    jackson tn
    I think I have the same noise it comes and goes though. I hear it on the drivers side and took my car back to ford but when I did it wasn't doing it.But it sounds like a lifter/rocker.
     
  3. steeltoe

    steeltoe Active Member Established Member

    Messages:
    3,956
    Joined:
    Jun 27, 2005
    Location:
    Washington, DC
    Ummm AFAIK we have solid lash adjusters. So they shouldn't make any noise. I priced out Jesel followers and lash adjuster and it was $2700 for a 3v 5.4.
     
  4. Devious_Snake

    Devious_Snake PSR Major! Established Member

    Messages:
    9,980
    Joined:
    Dec 25, 2011
    Location:
    Hell
    The jesel roller rocker ones are 1900 and the oem replacement ones are 700, via MMR.

    Just went on tasca, the lifters are cheap and so are the rocker arms. Obviously I would need to make sure thats the issue before I start replacing stuff.
     
    Last edited: Feb 26, 2014
  5. Snoopy49

    Snoopy49 Well-Known Member Established Member

    Messages:
    6,606
    Joined:
    Jun 12, 2012
    Location:
    California
    Is there any chance that it could be fuel injector noise?
     
  6. BlownAway03

    BlownAway03 Active Member Established Member

    Messages:
    1,201
    Joined:
    Jun 14, 2006
    Location:
    South Carolina
    I had the same type of issue with my 03 Cobra. It turned out to be the lash adjusters. It's almost impossible to find exactly which ones are bad so if that's what it turns out to be, just replace all of them. Just find out what side the noise is coming from. It's not that bad once the valve cover is off.
     
  7. BlownAway03

    BlownAway03 Active Member Established Member

    Messages:
    1,201
    Joined:
    Jun 14, 2006
    Location:
    South Carolina
    They can cause noise if they aren't pumping all the way up. That's the issue I had. The factory lash adjusters are pretty cheap.
     
  8. Devious_Snake

    Devious_Snake PSR Major! Established Member

    Messages:
    9,980
    Joined:
    Dec 25, 2011
    Location:
    Hell

    No, the injectors are noisy but I know what they sound like. This noise is clearly different.

    Yea my plan was to just make sure what side and replace all of them. Easiest way. Plus fresh oil just to be sure.
     
  9. steeltoe

    steeltoe Active Member Established Member

    Messages:
    3,956
    Joined:
    Jun 27, 2005
    Location:
    Washington, DC
    So they are hydraulic? hmm why did I think they were solid.
     
  10. raustin0017

    raustin0017 Well-Known Member Established Member

    Messages:
    1,049
    Joined:
    Dec 14, 2012
    Location:
    Charleston SC

    Why not have it fixed under warranty? You paid for it....
     
  11. 2011 gtcs

    2011 gtcs GT500 poster Established Member

    Messages:
    7,232
    Joined:
    Mar 7, 2011
    Location:
    Arizona
    Just out of curiosity, what type of oil and filter are using?
     
  12. Devious_Snake

    Devious_Snake PSR Major! Established Member

    Messages:
    9,980
    Joined:
    Dec 25, 2011
    Location:
    Hell

    Because the car is modded, pay to play. Plus ford sucks big hairy cow nuts


    I was using amsoil 10w40 and filter


    It should be noted I am not bitching about it, I drive the piss out of the car
     
  13. 2011 gtcs

    2011 gtcs GT500 poster Established Member

    Messages:
    7,232
    Joined:
    Mar 7, 2011
    Location:
    Arizona
    Stop running that oil, run 5W50 oil and only Ford oil filters, you will damage your cylinder head/engine I promise
    This is what happened to my 08 GT500 from running AMSOIL 10W40 and AMSOIL filters, read the hole thread
    http://www.svtperformance.com/forums/svt-shelby-gt500-150/967902-piston-slap-ticking-knocking.html
    I'm not knocking AMSOIL at all, but are engines don't like 10W40 oil
     
  14. cdh027

    cdh027 Member Established Member

    Messages:
    881
    Joined:
    Sep 13, 2003
    Location:
    Chicago
    I hope this isnt true. I just spent a bunch of money on Amsoil lubricants including 10w40.
     
  15. USV8PWR

    USV8PWR Member Established Member

    Messages:
    892
    Joined:
    Mar 10, 2012
    Location:
    Austin TX
    Regardless if you have a warranty in tact or not, I'd see if 1) the dealer will look at it for free and 2) if they find anything wrong if they'll cover it. It's not a blown motor yet. Give it a try Devious! Regardless, I'd rather have a Ford technician look at the engine and figure out what the noise is than all of us guessing what it could be. My .02 man.
     
  16. 2011 gtcs

    2011 gtcs GT500 poster Established Member

    Messages:
    7,232
    Joined:
    Mar 7, 2011
    Location:
    Arizona
    I would not recommend it, A friend of mine is Ford tech and verified that the cylinder head was damaged if you read the hole thread I documented everything I did to try and fix it. He was almost 95 percent sure that the wrong weight oil caused the damage. There is a TSB about it.
    But you guys can do whatever you want, AMSOIL makes awesome stuff, and I'm not knocking them in anyway, I just wouldn't run 10W40 in are engines
     
  17. BOSSPOWER

    BOSSPOWER Active Member Established Member

    Messages:
    1,495
    Joined:
    Jun 21, 2013
    Location:
    Miami, FL
    1+++

    Manuel
     
  18. biminiLX

    biminiLX never stock Premium Member Established Member

    Messages:
    11,119
    Joined:
    Jan 17, 2003
    Location:
    Toledo, OH
    Bummer bro, hoping for an easy fix.
    -J
     
  19. spitin venom

    spitin venom ~*~*~*~*~*~*~*~ Established Member

    Messages:
    3,127
    Joined:
    Nov 5, 2006
    Location:
    SoCal
    I remember you going through that.

    Over the past couple months I have read a few threads about ticking GT500 engines and the main thing I notice is that all the people with the problem were running Amsoil 10w40 and Amsoil filters.
     
    Last edited: Feb 27, 2014
  20. crucianpilot

    crucianpilot Feel the need for speed! Established Member

    Messages:
    345
    Joined:
    May 30, 2013
    Location:
    orlando, fl
    Doesn't Amsoil guarantee any engine repair when using their oil?
     

Share This Page