• Welcome to SVTPerformance!

Contour svt idle issues

Discussion in 'SVT Contour' started by acer5, Nov 20, 2012.

  1. acer5

    acer5 New Member Established Member

    Messages:
    24
    Joined:
    Nov 20, 2012
    Location:
    Victorville, California
    Hey guys, i cleaned out my throttle body and egr passageway to get rid of the p0141 code and it did but now my csvt idles around 2000 rpm and doesnt ever go away?? help plz?:shrug:
     
  2. CSVT5416

    CSVT5416 New Member Established Member

    Messages:
    102
    Joined:
    Aug 22, 2012
    Location:
    Tennessee
    My idle air control valve went bad on my SVT. Unplug it and see if your car idles down. If it does I'd say your valve is bad.
     
  3. blowns281

    blowns281 GARAGE QUEEN Established Member

    Messages:
    4,440
    Joined:
    Jul 25, 2003
    Location:
    Pennsylvania
    Make sure the throttle body closes all the way, if so try cleaning the IAC valve
     
  4. acer5

    acer5 New Member Established Member

    Messages:
    24
    Joined:
    Nov 20, 2012
    Location:
    Victorville, California
    It does go down when i unplug it but my IAC valve is brand new it only has 500 miles on it and it does close all the way and it still idles high... when i first start up the car the idle will go down to 800 but as soon as i give it some throttle it idles high after?
     
  5. CSVT5416

    CSVT5416 New Member Established Member

    Messages:
    102
    Joined:
    Aug 22, 2012
    Location:
    Tennessee
    That what mine does. I've talked to SVT Jared and he seems to believe I have a vacuum leak. Bc his wont even idle at all with it unplugged. So somthing is feeding our engine air.
     
  6. crewchiefpro

    crewchiefpro Member Established Member

    Messages:
    40
    Joined:
    Jan 16, 2010
    Location:
    Peoria, IL
    You have an intake leak. Try listening to the sound of unmetered air in the engine compartment. Probably a big leak to make the RPM that high. I use brake clean spray to identify the area where the leak is. Should be pretty obvious once you spray close.
     
  7. acer5

    acer5 New Member Established Member

    Messages:
    24
    Joined:
    Nov 20, 2012
    Location:
    Victorville, California
    what will it do if u spray close?
     
  8. cSVTinMO

    cSVTinMO New Member

    Messages:
    1
    Joined:
    Jun 20, 2013
    If it is your IAC valve on thing I've done when I'm really low on cash is take the IAC valve out and clean it out first, the. Put some brake fluid on that little rubber boot-thing so it won't be quite as dry and it expands a little bit. Some broke college kid advise right there lol.
     
  9. scottad73

    scottad73 New Member

    Messages:
    4
    Joined:
    Aug 17, 2013
    Location:
    Austin, TX
    It would increase your idle speed.
     
  10. bobrules

    bobrules New Member Established Member

    Messages:
    32
    Joined:
    Jun 29, 2007
    Location:
    Denver PA
    My car is doing the same thing. I checked for leaks replaced iac cam sensor crank sensor egr dpfe and still no help.
     
  11. zack.reynolds93

    zack.reynolds93 New Member

    Messages:
    4
    Joined:
    Oct 17, 2012
    Location:
    jackson mi
    well your not supposed to clean your IAC just buy a new one i had the same isue on startup it would idle high then go to about 800 then when given throttle went up to 3000 and stayed there for a good 20 sec i replaced the iac valve and problem solved i got it on ebay for 20 bucks new
     
  12. SicilianSVT

    SicilianSVT New Member

    Messages:
    6
    Joined:
    Dec 11, 2018
    Location:
    Brownwood Tx
    My svt is doing the same thing. I am in the midst of fixing mine up tho. I replaced all my vacuum leaks with new hoses. My IAC valve is old and it has about 10k miles on it. I am just going to replace it with a new one and see if it changes anything. Id like to get a motorcraft but i know they will be more expensive. What brand is the next best one to go with?? Thanks
     

Share This Page