• Welcome to SVTPerformance!

VMP pulley adapter?

Discussion in 'SVT Shelby GT500' started by 02cobragt, Jun 3, 2016.

  1. 02cobragt

    02cobragt New Member Established Member

    Messages:
    14
    Joined:
    Mar 15, 2015
    Location:
    Upstate sc
    I have a 2011 Shelby and bought a VMP pulley adapter and 2.6 pulley for the stock blower. Installed hub flush with shaft and the pulley locks down and won't turn when you snug bolts up. I pulled the hub out 1/8 inch and still locking down. Pulley is hitting blower snout. Could I have the hub on backwards to cause this issue?
     
  2. ZOMBEAST

    ZOMBEAST Killed by Death Established Member

    Messages:
    1,591
    Joined:
    Aug 31, 2008
    Location:
    North Jersey
    The 6 bolt hub is only for TVS blowers.
     
  3. Mainn

    Mainn Member Established Member

    Messages:
    458
    Joined:
    Jan 1, 2012
    Location:
    SA, Australia
  4. 02cobragt

    02cobragt New Member Established Member

    Messages:
    14
    Joined:
    Mar 15, 2015
    Location:
    Upstate sc
    Yes, 6 bolt hub is what I have.
     
  5. builttodrive

    builttodrive Member Established Member

    Messages:
    484
    Joined:
    Oct 26, 2014
    Location:
    Sioux Falls, SD
    I see the problem. Just need to get yourself a TVS blower...problem solved!:-D
     
  6. 02cobragt

    02cobragt New Member Established Member

    Messages:
    14
    Joined:
    Mar 15, 2015
    Location:
    Upstate sc
    I got it to work!!
     
  7. builttodrive

    builttodrive Member Established Member

    Messages:
    484
    Joined:
    Oct 26, 2014
    Location:
    Sioux Falls, SD
    Nothing a little machine work couldn't fix but watch that the belt rides in correct alignment or you will be in trouble.
     

Share This Page