Trans Problems NEED HELP!

99RioRedCobra

New Member
Established Member
Joined
Jul 1, 2010
Messages
54
Location
Wisconsin
I just recently put in a new stage 2 Ram Clutch in my 99 Cobra I also drained the trans fluid and put new Mobil 1 synthetic trans fluid in it and ever since that my trans hasn’t been able to go in to gears at high RPMs easily so I drained that out and put in regular trans fluid in it helped a little but still wont go in gear right away it almost like a hesitation but no grinding but when I’m just driving her normal and easy it will go in and out of the gears just easy as can be

This never happened before the clutch install ,trans is a T-45

If you have any ideas of what this could be please give me some feed back
 
Last edited:

Jaysin

Well-Known Member
Established Member
Joined
Jun 26, 2007
Messages
1,871
Location
Ga
Maybe the clutch cable needs adjusting? Still on the stock cable?
 

01yellercobra

AKA slo984now
Established Member
Joined
Oct 5, 2005
Messages
17,925
Location
Cali
You need to upgrade to an aftermarket quadrant. The stock one wasn't designed to handle a heavier clutch.
 

99RioRedCobra

New Member
Established Member
Joined
Jul 1, 2010
Messages
54
Location
Wisconsin
ok would i find them on like Americanmuscle.com what brand should i get also with the throw out bearring that was replaced and is now JUNK is there an upgraded one of them offered in the market??
 

01yellercobra

AKA slo984now
Established Member
Joined
Oct 5, 2005
Messages
17,925
Location
Cali
I'm currently running the Maximum Motorsports set up. I've also used UPR and Steeda with no real issues. As for the TOB, a lot of people go with a stock replacement. I manged to find a Timken replacement at a local store and haven't had any issues yet.
 

99RioRedCobra

New Member
Established Member
Joined
Jul 1, 2010
Messages
54
Location
Wisconsin
where would i be able to find a input shaft tube/ bearing retainer for a T45 ??cause all i find is shit for the T5 cant find for T45
 

nasty99

New Member
Established Member
Joined
Jun 2, 2011
Messages
89
Location
New Jersey
similar car similar problem. had to get my throwout bearing fixed cuz it was whining bad. so i bought a clutch while i was at it and got the ram clutch. tranny still whines, and my clutch cable that came wit the ram kit snapped now i have a bbk cable -__- hopefully it lasts, and hopefully my T-45 doesnt go bad........................
 

cobraetti

part of the zombie squad
Established Member
Joined
Jul 8, 2007
Messages
1,528
Location
goose creek,sc
I know I went with the UPR quadrant and FWA and it made a huge difference I was getting alot of cable slack.
 

Users who are viewing this thread



Top