• Welcome to SVTPerformance!

S480/485

Discussion in 'Turbo Cobras' started by lightningkid831, Oct 8, 2017.

  1. lightningkid831

    lightningkid831 Member Established Member

    Messages:
    103
    Joined:
    Jan 30, 2009
    Location:
    TX
    Has anyone used an s480 or s485 between the motor and radiator? I've got a cg fab kit, and thinking about running a forced inductions s485, just wondering about fitment. Any pictures would be appreciated!
     
  2. Nightmare302

    Nightmare302 OhChuteRacing Owner Established Member

    Messages:
    1,783
    Joined:
    Jan 11, 2004
    Location:
    Lawrence Kansas
    You'll need to push the radiator forward in the core support and/or use a slim fan.
     
  3. lightningkid831

    lightningkid831 Member Established Member

    Messages:
    103
    Joined:
    Jan 30, 2009
    Location:
    TX
    Yeah, I knew I would need to push the radiator forward. Planned on either doing a slim fan or pusher fans. Mainly just wanted to see pics of one of these giant turbos stuck between the radiator and motor lol
     
  4. Lstruck03

    Lstruck03 Man Pedal User Established Member

    Messages:
    3,454
    Joined:
    Oct 19, 2007
    Location:
    Texas
    I run an s482, my radiator is bigger than factory, and still in the factory location. We did have to modify the merge pipe at the t4 flange, and make it more of a straight angle, and i chose to run dual pusher fans infront of the condenser. Then I built a custom cooling crossover delete.
     
  5. Packerfan88

    Packerfan88 Member Established Member

    Messages:
    501
    Joined:
    Jan 4, 2014
    Location:
    Az
    any cooling issues Lstruck03? i did the two pusher in front of the condenser and had issues here in az...maybe they were not strong enough. i had to get rid of the condenser in order to run 3 core rad and keep stock fan...wont ever get rid of ac again. building my 97 cobra thats why i ask.
     
  6. cobranick01

    cobranick01 New Member Established Member

    Messages:
    26
    Joined:
    Oct 7, 2015
    Location:
    chicago
    I know this an old thread, but s485 with a cg fab hot side 75da479bf182bb1b01b89a4da54601df.jpg

    Sent from my SM-G955U using Tapatalk
     
    gimmie11s likes this.
  7. MTBSully

    MTBSully Well-Known Member Established Member

    Messages:
    4,142
    Joined:
    Sep 7, 2009
    Location:
    Portsmouth, NH
    Where is your MAF? Speed density maybe? Good looking setup
     
  8. badcobra

    badcobra It's Fast Established Member

    Messages:
    2,205
    Joined:
    Aug 25, 2004
    Location:
    Mpls/St Paul, MN
    That's got LS coils, definitely an aftermarket ECU.
     
    MTBSully likes this.
  9. cobranick01

    cobranick01 New Member Established Member

    Messages:
    26
    Joined:
    Oct 7, 2015
    Location:
    chicago
    Big stuff 3

    Sent from my SM-G955U using Tapatalk
     
  10. cobranick01

    cobranick01 New Member Established Member

    Messages:
    26
    Joined:
    Oct 7, 2015
    Location:
    chicago
    Couldn't figure out how to drag the video here to see better fitment. So I started a new thread for people that want to see.

    Sent from my SM-G955U using Tapatalk
     

Share This Page