• Welcome to SVTPerformance!

Will DEATSCHWERKS DW300 or Aeromotive Stealth 340's fit inplace of Walbro GSS342's

Discussion in 'The Distillery' started by Jroc, Mar 5, 2011.

  1. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    The pictures posted of the Fore Hat were of my car. I got these pumps when they were 1st available and tried to make it fit in the Fore Hat .
    The one thing that makes it difficult is the design of the socks on the 11142 Aeromotive pumps. It makes fitting them in the tank very difficult.

    Now for the Bad News.

    When trying to fit them I broke the fittings on two pumps they would not go in easily so I left the pumps without socks. Only the 11140 Center inlet pump sock works the best .
    Went to the track and On the 2nd pass both pumps without socks seized up . I believe they over heated . I spoke to a friend of mine with a 1200 hp Supra, and he said that the sock keeps the fuel from air rating b/c of the turbine. They had similar problems with Walbro's and burned up 5 pumps.
    So its very important to keep the socks on.

    It seems to Me that maybe the Aeromotive 340 11140's will work best because of the sock design is similar to Walbro's .

    Ive already made another change , Im ordering 3 DW300 pumps because of there waranty and 100% claim on E85 , but Im getting 3 Walbro replacement socks which will attach to the DW300 pumps . This way there is no difference in the way they fit on the Hat.

    For those that dont know and are saying they are fatter and wont fit , the pumps are identical.

    dw300_fuelpump_drawing.jpg

    Aeromotive340techspecs2.jpg


    Pete
     
    Last edited: Apr 25, 2011
  2. Jroc

    Jroc Active Member Established Member

    Messages:
    7,904
    Joined:
    Feb 3, 2007
    Location:
    SC
    Good deal.

    Let us know how the DW300's work out for you. :beer:
     
  3. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    New pumps on the way will post pics up next week when I switch out the pumps. Already have the Walbro Socks , and the Rebuild kit for the Fuel Pressure Regulator.
    Im taking the day off on Thursday to work on the car so I should be able to post pics Thursday night if not Friday.


    Pete
     
  4. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    Here's an update for everyone , pumps installed direct fit . the polarity of the deatschwerks is the same as the Walbro so its a direct fit.


    pumps2.jpg

    pumps1.jpg

    Pete
     
  5. alpha06

    alpha06 SKY 600 Established Member

    Messages:
    544
    Joined:
    Dec 20, 2006
    Location:
    Alexandria, LA.
    Good to know that they will fit! I just installed my Jay Racing PT342 Pumps today. I hate how the pumps with the socks bottom out in the tank. It seem that you have to have the sock just right so the Hat sits flushon the tank. When will you be through with your set-up?
     
  6. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    Im done car is running , holds pressure great , you dont even hear them .
    I run two pumps all the time the 3rd pump comes in at 15 psi's activated by a Hobb switch .

    I also put a new fuel pressure regulator diaphram/ rebuild kit.

    Took it around the block and smoked the tires . from a 30 roll . Im back in
    action.
    Maybe tomorrow I'll retune the car with my Buddy Willie Figueroa , and turn the boost up to 27 psi's .

    My tune right now is a bit rich because we tuned during the winter , now its hot and humid so the tune is a bit off.

    If your looking to change the fuel sock contact Walbro Electric Fuel Pumps for Street and High Performance from Fuel-Pumps.net, Walbro part# 1250572 .

    I didn't use the fuel socks that came with the Deatschwerks I knew I might have a fitment issue. trying to fit three of them so I bought the Walbro one's they fit perfect .


    Pete
     
  7. Jroc

    Jroc Active Member Established Member

    Messages:
    7,904
    Joined:
    Feb 3, 2007
    Location:
    SC
    ^Awesome man!

    Now we need to get Lethal to offer this as an alternative to the Walbro's.
     
  8. 95SC

    95SC Banned

    Messages:
    4,927
    Joined:
    Oct 5, 2004
    Location:
    MI
    It's great to know they fit. I just received my 3 DW300 pumps so we will see shortly if they fit Fore hat [ GT pumps design one] . if you don't mind how much did you pay for one DW300 pump ?
     
  9. alpha06

    alpha06 SKY 600 Established Member

    Messages:
    544
    Joined:
    Dec 20, 2006
    Location:
    Alexandria, LA.
    For those who installed pumps in there Fore Hats, Do your pumps sit flush on the bottom of the gas tank?
     
  10. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    169.00 ea.

    If you fit 3 Walbros' then nothing changes by switching to DW300s , there identical in size . You may need to buy new fuel socks to fit properly .



    They fit exactly the same as the Walbros all you need to do is buy the Walbro socks part # 1250572.



    Pete
     
  11. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    Today made a hit on the freeway , turned up the boost a/f was a solid 11.3 pulled like a freight train felt great.

    boost.jpg

    Never ran this much boost before :thumbsup:


    Pete
     
  12. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    Id like to point out that these pumps need 13.5v to flow the advertised numbers. It would probably be best to run a separate power wire for each pump. Im having a small pressure drop issue and I think its because of wiring.
    When I jump the hobb switch and the pump is running full time the pressure goes up and stays steady . Im doing some more testing today to see if its voltage related or maybe I need to raise the pressure at the rail a little . Stay tuned. :beer:
     
  13. 99cobrajn

    99cobrajn cant touch this........ Established Member

    Messages:
    2,223
    Joined:
    Oct 27, 2005
    Location:
    Marion Iowa
    95sc did these fit int the ford gt pump hat?
     
  14. 284T76

    284T76 New Member Established Member

    Messages:
    61
    Joined:
    Aug 1, 2005
    Location:
    Miami
    Everything is good. Checked the voltage , from my relays straight to the pumps and they were at 12.6v so I may just install a BAP to make sure I can feed them 13.5 to 14.0v.
    I bumped up the pressure at the rail to 46 psi's with vacuum off, and also replaced my hobb switch to come on a little sooner at 7 psi's . Pressure stays solid now . :banana:


    Pete
     

Share This Page