• Welcome to SVTPerformance!

Two snapped clutch cables. What gives?

Discussion in 'Driveline' started by Avispa, Aug 5, 2019.

  1. Avispa

    Avispa Member Established Member

    Messages:
    480
    Joined:
    Nov 9, 2008
    Location:
    Richmond, TX
    Just broke the second of two MMS replacement clutch cables in 9 months. Have a 3 hook aluminum quadrant, firewall adjuster and Spec Stage 2+ clutch with reduced pedal pressure; it's nowhere near as hard as a stock clutch. Both times, the cable snapped at the quadrant end. Supposedly the MMS cables are equal to OEM Ford for strength, they just don't have the "plug" on the firewall end. Is that right or should I get a Ford cable and cut off theplug?
     
  2. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,900
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Make sure the quadrant and cable are aligned. If the quadrant moves the cable will ride on the corner and it'll cut the cable. I went through that with a UPR quadrant.
     
    *Jay* and DSG2003Mach1 like this.
  3. P49Y-CY

    P49Y-CY selfie deaths ftw Established Member

    Messages:
    10,193
    Joined:
    Jun 21, 2003
    Location:
    south oc, cali
    Usually you need some washers at the pivot shaft of the quadrant to keep it lined up.

    Lol slow98 tree'd me
     
  4. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,900
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    It's another busy day at work. :)
     
    P49Y-CY likes this.
  5. Avispa

    Avispa Member Established Member

    Messages:
    480
    Joined:
    Nov 9, 2008
    Location:
    Richmond, TX
    Well that would explain it. Thanks for the replies. Alignment check it is!
     
  6. jbou91

    jbou91 Active Member Established Member

    Messages:
    460
    Joined:
    Oct 3, 2012
    Location:
    Chicago, IL
    Why don't you go with OEM?
     
    me32 likes this.
  7. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,900
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    If he's using the cables from Maximum Motorsports (which I'm assuming he is going by the "MMS") then he is using an OEM quality cable.
     
  8. hotcobra03

    hotcobra03 Well-Known Member Established Member

    Messages:
    6,085
    Joined:
    Mar 11, 2007
    Location:
    poteet,texas
    This may sound stupid.

    But remove cable and lube inside

    I had this issue.

    Snapped 2 in 1 week
     
  9. Frankycheechoo

    Frankycheechoo Member Established Member

    Messages:
    55
    Joined:
    Nov 26, 2017
    Location:
    Vaughan
    I switched to all MM KIT from just the cable MM and quadrant was BBK I don’t feel a difference . I don’t know what all this talk about MM cable , quadrant , adjuster, and lube it up works better , seems the same .



    Sent from my iPhone using svtperformance.com
     
  10. me32

    me32 BEASTLY SHELBY GT500 TVS Established Member

    Messages:
    12,441
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    You sure the cable isnt rubbing?
     

Share This Page