• Welcome to SVTPerformance!

Question about Whipple 2.3 Oil

Discussion in 'The Blower Bistro' started by Beerdog80, Aug 11, 2019.

  1. Beerdog80

    Beerdog80 Crazy Oklahoman Established Member

    Messages:
    1,292
    Joined:
    Jul 1, 2011
    Location:
    Oklahoma
    I recently got my built Lighting back together and have been driving it around Texas without issue for a couple of months...but today when I was detailing the bay, I noticed this:

    _q-rXlRGFP1yyUAwLCsMu9bYOf5rsksvV2gTB0JQd_eP16Im6rgqOEl696uUU88IBvLoNTZcoMzUi4vXa=w3840-h1868-no.jpg

    So...sucked out the oil and this is what it looks like. Around 7k miles since it was all installed.

    G9i1_cME6ksGQ921HNqM6iDa4mjsXBN9zCYfskVbXgcErycjntRP9K6bZ47bXWfvn11zAbKG0MxcVsHu15=w948-h1948-no.jpg

    Fs8NGpQ1xcScce0MkCK277RINuwudlS7BgCn1TyLHq7EjkqvkCt6nbwpBLEr_7ir97AZCJthgKMoYi4Uum=w948-h1948-no.jpg

    Anyone else ever had this happen? This is my first Whipple. I've run AutoRotor and KB's in the past this is a new one to me.
     
  2. SID297

    SID297 OWNER/ADMIN Staff Member Administrator

    Messages:
    47,655
    Joined:
    Mar 27, 2003
    Location:
    Myrtle Beach, SC
    How does it look after it has settled?
     
  3. Beerdog80

    Beerdog80 Crazy Oklahoman Established Member

    Messages:
    1,292
    Joined:
    Jul 1, 2011
    Location:
    Oklahoma
    Top pic is when its settled. I haven't started it up today.
     
  4. StacyStangz

    StacyStangz "Supercharged Stacy" - PR Established Member

    Messages:
    1,037
    Joined:
    Nov 24, 2003
    Location:
    NC/SC
    Any chance someone mixed oil? I highly recommend shooting Whipple an email asap with these photos along with your build and blower details to [email protected].
     
    tvspower likes this.
  5. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,736
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    Any metal pieces or just dirty?
     

Share This Page