• Welcome to SVTPerformance!

out with the new and in with the old. (build thread)

Discussion in 'Pics and Videos Buffet' started by 1967eleanor, Feb 15, 2010.

  1. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    see below.

    Basically the trunk thats on the car is only temporary, When I run any sort of weather stripping/latch it will not align, no matter what I do. The inner frame of the trunk would have to be completely cut/sectioned/rebuilt. In addition I am not happy with the quality of it at all. When I repaint the car in a year or two it will be getting replaced. :bash:

    This is with the weatherstripping in. (old one from when the car was first on the road) its funny to see how far the car has come since then lol

    [​IMG][/IMG]

    But you can see how messed up the gap is.

    and currently with just the latch.:bash::bash:

    [​IMG]
     
  2. RIO RED SNAKE

    RIO RED SNAKE 4:10's = The Suck Established Member

    Messages:
    5,233
    Joined:
    Jan 4, 2009
    Location:
    So FLA
    attention to detail is superior, love this thing, very nicely done, keep the updates coming
     
  3. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    car is out of storage and is getting some maintenance/loose ends tied up. More info to come Monday. I am graduating this weekend so Ill be out of town.

    hanging out with the daily, shows you how small/low the car actually is lol

    [​IMG]

    [​IMG]
     
    Last edited: May 17, 2013
  4. blubyu90

    blubyu90 Member Established Member

    Messages:
    255
    Joined:
    Feb 11, 2004
    Location:
    marietta, ga
    Man I love this thread and the car!!!
     
  5. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    Been spending some time doing little odds and ends that I've been over looking.

    first off this eye sore.
    [​IMG]

    [​IMG]

    while I was polishing my valve covers and air cleaner fins I decided to polish the top of the rad. At first I wasnt gonna do it but it looks good. Its not a mirror shine so I like it. It has a finished look to it.

    [​IMG]

    [​IMG]

    another thing I have to do is paint the fanshroud black.

    [​IMG]

    I also noticed the centers of my wheels are starting to age nicely. They are starting to get the bronze color that the movie car wheels had on them. It really ties them into the car much more now. Im going to take the wheels off an polish them inside and out, they need it badly.

    [​IMG]

    compared to 3 years ago.

    [​IMG]


    and over the weekend one of the original movie cars sold at mecum for $1 million dollars :lol1: :banana: 302/4speed car. Impressive to say the least.

    DSCN2301_zps342d1e9a.jpg

    [​IMG]


    couple movie clips from mecum

    Eleanor Hero Car Sells at Mecum for $1 Million - YouTube

    1967 Ford Mustang Eleanor - Gone in 60 Seconds Hero Car - YouTube
     
    Last edited: May 20, 2013
  6. Gray_Ghost

    Gray_Ghost Active Member Established Member

    Messages:
    2,171
    Joined:
    Feb 13, 2008
    Location:
    Rome, GA
    As always, stunning work. Anyway, The hero car didn't even have a proper drivetrain?! It just went from "gotta have it" to "meh".
     
  7. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    none of the film cars had a 428/4 speed. The sounds your hear were all small blocks. There was 1 390 car.
     
  8. Gray_Ghost

    Gray_Ghost Active Member Established Member

    Messages:
    2,171
    Joined:
    Feb 13, 2008
    Location:
    Rome, GA
    Yeah, I just thought the so called "hero" car would have had everything. Oh well.
     
  9. RustyRodder

    RustyRodder Fauxbra powered Established Member

    Messages:
    1,234
    Joined:
    Nov 2, 2007
    Location:
    Albany, NY
    Lookin great as always, Dave!


    This page is stretched more then your MKII's tires!
     
  10. gamebred26

    gamebred26 Active Member Established Member

    Messages:
    1,915
    Joined:
    Aug 29, 2010
    Location:
    nj
    eleanor just sold for a million at mecum!
     
  11. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    i dont any cars with stretch anymore.......:nonono:
     
  12. BLK93GT

    BLK93GT Active Member Established Member

    Messages:
    2,490
    Joined:
    Mar 7, 2003
    Location:
    Plattsburgh,NY
    From what I can remember they used a 67 GT500 with a modified 428 motor for the sound.

    Sent from my MB865 using Tapatalk 2
     
  13. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    some more cleaning, also polished the lips and inner barrels of the wheels. just needs a wash and some nice weather!!

    [​IMG]
     
  14. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    Had a wonderful day outside 70 and not a cloud in the sky, so I decided to go to a show. First time having the car out.

    thought i was gonna have the most bitchin day well that went south in a hurry.

    The slave which was less than a year old decided to puke its guts out.

    [​IMG]

    and for the first time since owning the car had to get it towed.

    [​IMG]
     
  15. Gray_Ghost

    Gray_Ghost Active Member Established Member

    Messages:
    2,171
    Joined:
    Feb 13, 2008
    Location:
    Rome, GA
    Damn, that sucks man. Time for an upgraded slave cylinder. ;-)
     
  16. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    Its a 7/8 bore. It should be PLENTY. Oh well I ordered a new one, so gotta wait another 3 days for that to come.
     
  17. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    slave was replaced and adjusted properly, All is good there. however a couple weeks ago I hit a bump, heard a pop, and noticed the front pass side of the car was sitting about an inch lower than normal. Caused by this

    olGf8v7.jpg

    which is supposed to look like this.

    GP4aD4v.jpg

    So shelled out another $100 for a replacement.

    otherwise ive been driving it back and fourth to work, and on nice days.

    [​IMG]

    with my brothers 03

    [​IMG]

    out to dinner on the lake.

    some chumps doing some posing in front of it.

    [​IMG]

    and the typical crowd around it all night.

    [​IMG]
     
  18. bleedingfordblu

    bleedingfordblu Active Member Established Member

    Messages:
    4,227
    Joined:
    Jul 14, 2008
    Location:
    Leesburg VA
    such a beautiful car but it kills me how narrow the rear tires are
     
  19. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    245 is what the car is supposed to have.
     
  20. 1967eleanor

    1967eleanor factory spoiler delete yo Established Member

    Messages:
    4,134
    Joined:
    Jul 7, 2005
    Location:
    Latham,NY
    been having a problem this year of the car running real lean, at idle it runs fine but while cruising the AFR was high 14s to high 15s sometimes even low 16s. Also having a lean miss while accelerating. On monday I went to take the car to work and it actually died out on me right after putting gas in it. I went to restart the car and the fuel pump would not prime. Eventually I did get the car started, changed the fuel filter, and pulled the pump assembly to find this.

    [​IMG]

    [​IMG]

    So I replaced it with a bigger pump 255lph vs the old 190

    [​IMG]

    Did not get a chance to drive the car yet but it seems to be a night and day difference. the car will start right up, idle perfectly even cold, and the pump is quieter.
     

Share This Page