• Welcome to SVTPerformance!

O2 Sensor Upstream Passenger Side - replacement tip?

Discussion in 'Engine/Tuning' started by cheeser, Sep 15, 2019.

  1. cheeser

    cheeser Member Established Member

    Messages:
    175
    Joined:
    Sep 28, 2012
    Location:
    CO
    I tried replacing this O2 sensor today, but couldn’t obtain enough slack in the harness in order to get my hand in in order to disconnect the sensor from the harness. I followed the instructions in the service manual except for the removal of one clip that’s near the top of the manual transmission...couldnt get a tool in there to push out or pull that Christmas tree style pin. I assume I need to pull this out in order to obtain the needed slack.

    I went ahead and ordered a bent retainer clip removal tool to see if that will help, in a addition to an O2 wrench vs the O2 socket I had.

    Curious if there is anything else that would simplify things? Wish Ford wouldn’t have made a simple task so hard.
     
  2. 96gt02

    96gt02 Well-Known Member Established Member

    Messages:
    1,294
    Joined:
    Jan 21, 2015
    Location:
    NJ
    I was lucky enough to be able to disconnect that harness from underneath somehow after trying for a while, however plugging it back in was impossible in my case, I ended up taking the battery and tray out and did from it from top, still not easy but was do-able
     
  3. cheeser

    cheeser Member Established Member

    Messages:
    175
    Joined:
    Sep 28, 2012
    Location:
    CO
    I took the battery and tray out as well, but didn’t help me. It seems that one last retainer clip (above skip shift connector?) that I can’t remove is the one that is preventing me from obtaining the needed slack.
     

Share This Page