New Deatcsh fuel pump seems to be working well---but has strange noise?

FIREBALL

Active Member
Established Member
Joined
Mar 5, 2016
Messages
400
Location
Calif
As most of you know I had to replace my fuel pump and with issues removing and installing. but i got it done and car is running fine. The Deatcsh pump makes a crazy noise when turning key on. there is about a 1 second screech, Is this normal? I know that the Deatcsh pump has what as described as a turbine pump (are they all turbine pumps?) but it doesnt sound good. I know that many have complaints about after market pumps making loud noises.
 
Last edited:

FIREBALL

Active Member
Established Member
Joined
Mar 5, 2016
Messages
400
Location
Calif
Its a pretty straight forward install and it went back together fine, what kind of install error would cause it to make that noise?
 

FIREBALL

Active Member
Established Member
Joined
Mar 5, 2016
Messages
400
Location
Calif
Same physical size as oem pump, but many have said Deatsch is one of the best and puts out more pressure.
 
Last edited:

01yellercobra

AKA slo984now
Established Member
Joined
Oct 5, 2005
Messages
17,930
Location
Cali
Same physical size as oem pump, but many have said Deatsch is one of the best and puts out more pressure. The noise is kind of like a large zipper being zipped up real fast.
Ok. I was thinking maybe it's longer so it wouldn't have as much clearance at the bottom to suck up fuel.

Don't forget aftermarket pumps are generally louder. I remember I could hear my GT pumps prime when I turned the key. My current 450's are pretty noticable before the car is started.
 

biminiLX

never stock
Established Member
Premium Member
Joined
Jan 17, 2003
Messages
11,508
Location
Toledo, OH
DW supplied the injectors (and I thought the pumps) on the current Cobra Jets and they seemed very knowledgeable at PRI, so I’d expect they are quality products.
You said issues removing and installing in first post, so I’d first suspect something incorrect on the install. Have you called DW?
Aftermarket high flow pumps are louder and you’ll notice the prime but not as the noise you’re describing.
DW should have a few troubleshooting options.
Good luck.
-J
 

FIREBALL

Active Member
Established Member
Joined
Mar 5, 2016
Messages
400
Location
Calif
My issues with removing and installing was mostly with the fuel line at the tank nipple, here is that thread https://www.svtperformance.com/threads/fuel-pump-stoped-working-i-think-car-wont-start.1194911/ The install of the pump was pretty straight forward with no issues---what would/could be incorrect with the install that would cause the noise??? The car is running well but the noise on initial key on is weird--------One theory that I have is the pump has some air trapped in it and it causing some cavitation noise. The fuel pressure is now 30--35, when I took the old pump pressure about a year ago it was around 15--20
 
Last edited:

FIREBALL

Active Member
Established Member
Joined
Mar 5, 2016
Messages
400
Location
Calif
Deatsch... I wouldn't be running any of there stuff.

Well the Deatsch screech noise started getting louder and since being installed there has always been a slight delay on firing up and lately there has been some sputtering at first start up sooo Deatsch pump is comming out, didnt want to take a chance of getting stranded somewhere. ---- After looking at many reviews I have chosen the Bosch complete assembly. After having the learning curve behind me dropping the tank was easy this time and I had replaced that ridiculous factory fuel line with a braided steel line with Red Horse connectors on both ends making it easy to connect and disconnect. I almost went with the expensive Motor Craft pump assembly but reviews are no so great.
 
Last edited:

shurur

Well-Known Member
Established Member
Joined
Jan 2, 2011
Messages
3,343
Location
Lutz, FL
Sorry that pump was a problem for you.
It has gotten good reviews, but shit happens.

Glad you dumped those lines as well.
Keep the OEM lines for the next guy.
 

shurur

Well-Known Member
Established Member
Joined
Jan 2, 2011
Messages
3,343
Location
Lutz, FL
Updating this thread for SVTP:
After troubleshooting everything along the line.....I must come to the conclusion that my DeatschWerks 340 fuel pump is dead now as well!!

I only had the one year warranty. But then why bother taking a chance with them again...period.

I will make an attempt to change out the filter, but filter is new and a motorcraft.
 
Last edited:

biminiLX

never stock
Established Member
Premium Member
Joined
Jan 17, 2003
Messages
11,508
Location
Toledo, OH
I run 3 Hellcat Walbro 285s and they’ve been fine. I’ve been told these pumps have counterfeiting problems so I recommend only buying from a legit dealer. Not worth saving $10-20.
-J
 

shurur

Well-Known Member
Established Member
Joined
Jan 2, 2011
Messages
3,343
Location
Lutz, FL
Ok..not my thread...but..related to the DW300M.

When I took the fuel filter out and connected directly to the FP only a bit of fuel spit out.

I found that my check valve had become unseated from the canister cover. It had slipped the tiny screw that holds the check valve housing into the depression for it to seat in the top cover. Fuel was spitting around the housing.

I used a small sheet metal screw to hold the check valve housing in place. She started right up.
 

Users who are viewing this thread



Top