Near suicide , 3k high idle problem

MaxSimoneau

Member
Established Member
Joined
Feb 19, 2015
Messages
126
Location
Quebec, Canada
Hi , I had a sticking BBK tb , and to compensate I openned the blades a bit more and readjusted the tps. But I was too far open , the car was not able to compensate .so I "sanded" the tb blades to try to eliminate the sticking tb when hot. Unfortunnatly I sanded them too much ...lol

So I installed the stock oem TB, readjusted the TPS. BTW with the same tune . Now no more sticky TB but high idle.. very high.. like 2500 rpm.
Installed a brand new TPS and IAC valve. Cleaned the AIT and MAF sensor.
Still high idle.. and seems like a vaccum issue because sometimes it idles at 2500 and when I give it gas a bit , the idle is hang to 3000-3200 rpm....
Looked at all the vaccum lines near the intake tube and behind the blower... found nothing
Even pulled the blower to inspect the hose under it...
Only problem I see is that I am using the tune tuned for BBK tb and now I am using the oem tb.. but dont think it could give problems like that?..

Please help dont know where to look for now..
 
Last edited:

01yellercobra

AKA slo984now
Established Member
Joined
Oct 5, 2005
Messages
17,942
Location
Cali
I'm going to assume the BBK was a twin blade throttle body. I don't remember if they even make a single blade throttle body.

When you installed the new TPS did you clock it correctly? I think there's a way to install it that will cause the blades to hang open. If that checks out what kind of shape is the gasket in?
 

MaxSimoneau

Member
Established Member
Joined
Feb 19, 2015
Messages
126
Location
Quebec, Canada
I'm going to assume the BBK was a twin blade throttle body. I don't remember if they even make a single blade throttle body.

When you installed the new TPS did you clock it correctly? I think there's a way to install it that will cause the blades to hang open. If that checks out what kind of shape is the gasket in?
Yes the blades are closed and the TPS is reading .94v.
The gasket between the tb and the elbow is in good shape

And BTW i also sprayed brake cleaner almost everywhere in the engine bay and no change at all
 

Attachments

  • 20210830_194603.jpg
    20210830_194603.jpg
    270.6 KB · Views: 35
Last edited:

03cobra#2

Hobbyist Of Many Hobbies
Established Member
Joined
Feb 9, 2007
Messages
1,259
Location
Cleveland, Ohio
All I can say is that air is getting in somewhere. Just for kicks you can unplug the iac while the engine is running and see what happens. When it's unplugged and nothing changes its possible the iac is bad or you have air getting past the tb blades.
 

Roots-type

+displacement
Established Member
Joined
Apr 26, 2008
Messages
2,423
Location
Tx
You say the car was tuned with the bbk tb. Was the car ever running good with it on there? That it has idle issues even now with the stock tb suggests it isn't tb related. The same tune should work between both tbs btw.

Any chance the throttle cable could be damaged causing it to stick? You might want to take it off and pull on it by hand and check if there's a rough spot in its travel. If that checks out, you may want to go ahead and smoke test it.

Also, if it comes down to a smoke test, be sure to watch the interior for smoke. That factory boost line that comes in behind the glove box and runs over to the gauge could be leaking. These cars are getting to that age and most have had multiple owners monkeying around with them by now. You just never know.
 
Last edited:

MaxSimoneau

Member
Established Member
Joined
Feb 19, 2015
Messages
126
Location
Quebec, Canada
You say the car was tuned with the bbk tb. Was the car ever running good with it on there? That it has idle issues even now with the stock tb suggests it isn't tb related. The same tune should work between both tbs btw.

Any chance the throttle cable could be damaged causing it to stick? You might want to take it off and pull on it by hand and check if there's a rough spot in its travel. If that checks out, you may want to go ahead and smoke test it.

Also, if it comes down to a smoke test, be sure to watch the interior for smoke. That factory boost line that comes in behind the glove box and runs over to the gauge could be leaking. These cars are getting to that age and most have had multiple owners monkeying around with them by now. You just never know.
throttle cable is operating freely.
And yes the car was running good before with the BBK tbs.

Please take a look at the TB/gasket in the picture above and the Blower elbow..
Maybe it doenst' seal right. Will test fit again and add RTV maybe ..
 

01yellercobra

AKA slo984now
Established Member
Joined
Oct 5, 2005
Messages
17,942
Location
Cali
How well does the gasket line up on the plenum side? To me it looks like the TB idle opening is bigger than the plenum opening. Maybe one of the VMP guys can chime in.
 

hotcobra03

Well-Known Member
Established Member
Joined
Mar 11, 2007
Messages
7,019
Location
poteet,texas
I had issues back in 05 with sticking throttle,,

During my testing,,

Tried a spring to pull back ,,no help and made driving such,

Only thing on mine that lowered rpm was actually using hand to hold throttle closed

A replacement was my fix,,
Still have the original, not sure if they are repairable,

It did spit a code for sticking throttle but not till the day I replaced it ,,strange
 

Users who are viewing this thread



Top