• Welcome to SVTPerformance!

Mil eliminators

Discussion in 'New Edge Cobras' started by Fordman1994, Jun 21, 2019.

  1. Blown38

    Blown38 Active Member Established Member

    Messages:
    767
    Joined:
    Jul 6, 2009
    Location:
    Dumfries, VA
    You can just use the canned tunes that come on the x4. You don't need to have ford flash it back to stock. And I would recommend against that. The x4 will just save what is in the EEC as the stock tune which the car runs on. You don't know what mods are done to the car. So the canned tunes might not run at all then you can go back to what is in there now.

    You need to find out what injectors, MAF and fuel pump are in it now before you try to get some tunes. Maybe not the fuel pump info, I don't know if your car is a returnless fuel system.
     
  2. Fordman1994

    Fordman1994 New Member Established Member

    Messages:
    29
    Joined:
    Nov 27, 2018
    Location:
    Illinois
    Stock maf, injectors. They replaced the fuel pump with a quantum pump. It also has a boost a pump on it. Still returnless. I think it just has LT's, off road x pipe, cold air intake and gears.
     
  3. Fordman1994

    Fordman1994 New Member Established Member

    Messages:
    29
    Joined:
    Nov 27, 2018
    Location:
    Illinois
    I'm thinking someone tuned it and it's not right. I dont know what else it could be. I replaced the maf and o2s. Took it to Ford they looked for leaks couldnt find anything that they thought would cause it.
     
  4. Fordman1994

    Fordman1994 New Member Established Member

    Messages:
    29
    Joined:
    Nov 27, 2018
    Location:
    Illinois
    It definitely has an aftermarket tune. I got my sct x4. It doesn't really change how it runs. I changed the calibration for the gears to 3.27 which is stock I believe. Speedo was almost 10mph off. I did the same with 4.10s and it was spot on. Why wouldnt someone return it to stock or give the tuner with the car? Should I check for a chip?
     
    Last edited: Aug 23, 2019
  5. slo984now

    slo984now AKA 01yellerCobra Established Member

    Messages:
    14,932
    Joined:
    Oct 5, 2005
    Location:
    San Diego
    If it had a chip you wouldn't be able to load the tune from the X4. Some people forget to give the handheld with the car. Or they think they can use it with another car without realizing it needs to be unlocked first.
     
  6. Fordman1994

    Fordman1994 New Member Established Member

    Messages:
    29
    Joined:
    Nov 27, 2018
    Location:
    Illinois
    Got my tune from vmp. Still getting lean codes. It also has a p0455 large evap leak code. I took it to Ford and they pressure tested it. They didnt find any leaks. Previous owner took it somewhere and said they thought it was a bad fuel tank pressure sensor. Could that cause a lean condition?
     

Share This Page