• Welcome to SVTPerformance!

Is brake squeal common?

Discussion in 'Wheels/Tires/Brakes' started by OG_, Sep 15, 2015.

  1. OG_

    OG_ New Member Established Member

    Messages:
    176
    Joined:
    Nov 19, 2012
    Location:
    Houston
    Picked up a new 2015 GT last month and I've been having brake squeal whenever I drive the car after it sits for a day (garage). It happens the first time I come to stop from a slow roll and it's L-O-U-D (turning heads loud) but goes away after I start driving. Anybody else have this issue? Asked my friend who works at ford and says it's common. True?
     
  2. Skrapmetal

    Skrapmetal Active Member Established Member

    Messages:
    2,950
    Joined:
    May 13, 2006
    Location:
    IA
    Pretty sure there is a TSB out for it for earlier 15 builds, but I could be wrong.
     
  3. whatsup62

    whatsup62 Member Established Member

    Messages:
    111
    Joined:
    Sep 9, 2015
    Location:
    Iowa
    Has been common on these cars. I ve seen where guys have taken back to the dealer and they replaced everything, I have seen where they have taken back and dealer says its normal and does nothing.
    I had the issue and heard it was because the brakes did not have a good seating. I took car out and put it through its paces accelerating and braking hard. Problem went away.
     
  4. OG_

    OG_ New Member Established Member

    Messages:
    176
    Joined:
    Nov 19, 2012
    Location:
    Houston
    I like this solution. Thanks! :D
     
  5. blackbeast12

    blackbeast12 Dr. Frankenstang Established Member

    Messages:
    3,929
    Joined:
    Apr 30, 2012
    Location:
    Delaware
    Brembos are known for squeaking but not head turning squeaks!
     
  6. OG_

    OG_ New Member Established Member

    Messages:
    176
    Joined:
    Nov 19, 2012
    Location:
    Houston
    I don't have Brembos though :( Just a GT premium w/ the 50th appearance package.
     
  7. krssrls

    krssrls New Member Established Member

    Messages:
    30
    Joined:
    Jun 15, 2015
    Location:
    Seabrook, TX
    I have one of the very early 15's build 490 and it has done it from day one. once the brakes heat up its all good.
     
  8. stunuts

    stunuts Member Established Member

    Messages:
    43
    Joined:
    Oct 10, 2007
    Location:
    San Clemente, CA
    I have the squeak but its only when coming to a slow stop, its more harmonic then a normal "squeak" you would get with worn out pads. I just chalked it up to a harder compound material with the performance pack.
     
  9. unix_usr

    unix_usr New Member

    Messages:
    2
    Joined:
    Mar 29, 2016
    Location:
    Lakeshore, Ontario (Canada)
    I had the same problem - MAKE SURE it's documented; even if they don't fix it - take it to a dealer, and complain. I did ... a few months later there was a TSB on the non-performance package, I argued with the dealership and ultimately they, (wanting to keep me a happy customer), replaced my break pads. I do have the Brembro brakes on the performance package GT - which is NOT part of the TSB... the pads alone are like $480 CAD. It seemed to fix the problem for the most part, but recently it's started again, most notably when coming to a slow/steady stop even more so on a slight incline. I will be taking it back to the dealer again - this is not acceptable to me on a brand new car with less than 20K miles on it. I am hoping to push them to change the rotors (that was what the TSB called for on the non-performance pkg breaks which are squealing).
     
  10. Zodiac

    Zodiac Active Member Established Member

    Messages:
    514
    Joined:
    Jan 4, 2013
    Location:
    Raleigh, NC
    I brought mine in to the dealer and they performed the TSB replaced pads and rotors.

    EDIT: looks like I responded to a thread brought back from the dead.
     

Share This Page