• Welcome to SVTPerformance!

Hesitstion/studdering & smoke on startup/higher rpm?

Discussion in '2nd Generation' started by itzHypn0tic, Nov 8, 2018.

  1. itzHypn0tic

    itzHypn0tic New Member Established Member

    Messages:
    25
    Joined:
    Feb 20, 2018
    Location:
    New Jersey
    So I finally got my truck back together after tearing it apart and putting remanufactured cylinder heads on it... The truck seems to have some hesitstion/studder when accelerating and burns oil on startup & higher rpms (blue-ish smoke). I'd guess valve seals are bad, but the heads were just cleaned up and they were supposedly replaced... (The company messing up is always a possibility). I compression tested every cylinder and the rings seem to be fine. The sparkplugs had a light coat of oil around the tips and I'm definitely down a good amount of oil after test driving it a little.

    Anyone have any thoughts or adivce? I also performed the turkey pan mod & installed a catch can, and trick flow valve covers (I read somewhere that these have some issues with PCV for some).

    I also hooked up my Modis to monitor the cylinder contribution when driving, and every once in a while there seems to be a small misfire, but not very often and it's not throwing a code.

     
  2. ashleyroachclip

    ashleyroachclip Well-Known Member Established Member

    Messages:
    1,623
    Joined:
    Jan 25, 2007
    Location:
    Oregon
    Pcv would be my first check .
    Blue can also be fuel
     
  3. itzHypn0tic

    itzHypn0tic New Member Established Member

    Messages:
    25
    Joined:
    Feb 20, 2018
    Location:
    New Jersey
    Wait... I'm dumb and didn't notice this until i watched my own video... The boost is a little funny...
     

Share This Page