• Welcome to SVTPerformance!

Guys using E-85 Check your fuel filters!!

Discussion in 'The Distillery' started by VenomSVT03, Dec 27, 2012.

  1. VenomSVT03

    VenomSVT03 CRUSHER Established Member

    Messages:
    1,570
    Joined:
    Mar 29, 2008
    Location:
    South Florida
    Today i checked my fuel filter for the hell of it and this is what i found. The fuel system is about 3 months old (complete fuel system 1200RWHP system from Lethal). I picked up a new filter immediately and put it in.

    badfuelfilter.jpg

    And this is comparing each other for reference

    badgoodfilter.jpg
     
  2. tmkr03

    tmkr03 Member Established Member

    Messages:
    211
    Joined:
    Jan 18, 2007
    Location:
    Oswego/Joliet, IL
    Hmm I'll pull mine over winter. How much do you drive?
     
  3. VenomSVT03

    VenomSVT03 CRUSHER Established Member

    Messages:
    1,570
    Joined:
    Mar 29, 2008
    Location:
    South Florida
    Since the new complete fuel system has been in, i say about 400 miles
     
  4. safado

    safado bleed'n blue Established Member

    Messages:
    1,025
    Joined:
    Sep 24, 2002
    Location:
    Phoenix
    I have put 8 tank fulls of E85 thru out the last 6 months.. I check the filter about a week ago and it looks like new... I wonder if its where your getting it from??

    2012-11-25113152.jpg
     
    Last edited: Dec 27, 2012
  5. Team Paulie

    Team Paulie New Member Established Member

    Messages:
    256
    Joined:
    Aug 29, 2012
    Location:
    Curtice Ohio
    That filter looks really familiar to me for some reason....what the inside of that thing look like?
     
    Last edited: Dec 27, 2012
  6. safado

    safado bleed'n blue Established Member

    Messages:
    1,025
    Joined:
    Sep 24, 2002
    Location:
    Phoenix

    I'm sure your asking the OP.... also OP.. do you test your fuel every fill??
     
  7. Robertp

    Robertp 2.9 crusher guy Established Member

    Messages:
    820
    Joined:
    Jan 24, 2008
    Location:
    carthage
    its the fuel hose, u need the hose like fore innovations sells thats teflon, that stuff rocks lethal 1200 hp hit uses regular hose unless u opted for the telfon upgrade
     
  8. bambinov8

    bambinov8 600WHP LOL Established Member

    Messages:
    2,702
    Joined:
    Feb 10, 2008
    Location:
    SOUTH FLORIDA
    That is the color I thought any e85 filter will look like. I will take mine out soon tonight and post a pic
     
  9. safado

    safado bleed'n blue Established Member

    Messages:
    1,025
    Joined:
    Sep 24, 2002
    Location:
    Phoenix
    I'm using non teflon cloth braided push lock hose.. so far so good...
     
  10. Mystic03

    Mystic03 Active Member Established Member

    Messages:
    6,626
    Joined:
    Apr 21, 2005
    Location:
    tucson,az
    like the lethal fuel line upgrade kit?
     
  11. vadorsnake04

    vadorsnake04 Active Member Established Member

    Messages:
    2,022
    Joined:
    Dec 11, 2005
    Location:
    Illinois
    My fuel filter always looked perfect when I ran E85. I did not run Teflon coated hose either.
     
  12. sallen85

    sallen85 Member Established Member

    Messages:
    460
    Joined:
    Feb 14, 2010
    Location:
    wisconsin
    Sub'n interesting
     
    Last edited: Dec 27, 2012
  13. safado

    safado bleed'n blue Established Member

    Messages:
    1,025
    Joined:
    Sep 24, 2002
    Location:
    Phoenix

    Dont know never seen the lethal hose.. I just get it from the parker store..
     
  14. c6zhombre

    c6zhombre E85 NutSwinger Established Member

    Messages:
    5,015
    Joined:
    Sep 14, 2008
    Location:
    League City, TX
    I've seen that condition filter posted here before...and I believe the issue was the E85 location did not have a brand new infrastructure...it was a location that had swapped that tank n pump over from a previous diesel setup

    do a search. swap the filter. try a new location with brand new infrastructure thats only been used for e85
     
  15. VenomSVT03

    VenomSVT03 CRUSHER Established Member

    Messages:
    1,570
    Joined:
    Mar 29, 2008
    Location:
    South Florida
    The gas station im getting e85 from was built brand new a few months ago, its a Turnpike service plaza. I just put a brand new filter today after seeing the old one. Ill give it about a month and take it back out and see how it looks
     
  16. KlugSS

    KlugSS New Member Established Member

    Messages:
    297
    Joined:
    May 29, 2011
    Location:
    Nebraksa
    Mine looked like yours after 2-3000 miles. I run stainless filters, clean then up with some brake clean and slap them back in.
     
  17. Blueline

    Blueline Active Member Established Member

    Messages:
    4,923
    Joined:
    Jan 27, 2011
    Location:
    New Jersey
    What hose are you running with your setup?
     
  18. black03

    black03 Authorized Vendor Authorized Vendor

    Messages:
    8,176
    Joined:
    Jul 4, 2002
    Location:
    paradise
    Since you just made the swap to E85 than it's completely expected to see a filter element look like that. Regular gasoline leaves residue inside your fuel tank. Just like if you leave gas in a gas can for a long time you'll see a line of scum/residue where the top of the fuel level is. Once you swap to E85 the ethanol breaks down all of that residue and where do you think it ends up? The filter.

    Since you've been running E85 for a few hundred miles the tank should be clean by now. However I'd check the new filter element in a month just to make sure.

    Hope that helps.

    Jared

    The hose has nothing to do with it as the standard push-lite hose from Fragola is compatible with E85. I've been using the same hose with E85 on our 2010 GT500 for the last few years without any problems whatsoever.

    Thanks, Jared
     
  19. VenomSVT03

    VenomSVT03 CRUSHER Established Member

    Messages:
    1,570
    Joined:
    Mar 29, 2008
    Location:
    South Florida
    Jared, I've been on e85 for almost 2 years. Since then my car has never seen 93
     
  20. black03

    black03 Authorized Vendor Authorized Vendor

    Messages:
    8,176
    Joined:
    Jul 4, 2002
    Location:
    paradise
    Could be a bad fill up then? I've been running Ethanol in our 2010 GT500 which uses the same hose and filter. Other than swapping out the first element shortly after we made the conversion the filters elements after that never looked like that.

    Jared
     

Share This Page