• Welcome to SVTPerformance!

GEM issue?

Discussion in 'Terminator Talk' started by Sprayed2v, Aug 1, 2019.

  1. Sprayed2v

    Sprayed2v Member Established Member

    Messages:
    153
    Joined:
    Jul 26, 2012
    Location:
    VA
    So I recently got to a point to where I can put break in miles on my cobra after a 3year build. After installing the Turbo kit the car ran great. I went out the other day to start it and noticed my brake lights arent working anymore. The lights themselves work fine since they come on with my headlights and turn signals, just not while braking, Also my windshield wipers and squirters dont work, neither does my auto roll down feature. My stereo was dead but I noticed the fuse had blown, I put another 15amp fuse in it and it blew again. I put a 20amp in just to see if the break lights would work and they didnt but the stereo came back on. All my other electronics work: power seats, mirrors, dome lights. I replaced the multi function switch and nothing still. Any advice before I C4 this thing? Thanks in advance.

    Sent from my SM-G965U using the svtperformance.com mobile app
     
    BLOWN9646 likes this.
  2. VA-Mach1

    VA-Mach1 Active Member Established Member

    Messages:
    436
    Joined:
    Mar 19, 2014
    Location:
    VA
    I had a similar issue once. Mine was the wire plug on the brake light switch on the brake pedal had melted and was grounding out. It was a easy fix. Good luck.
     
    Sprayed2v likes this.
  3. BLOWN9646

    BLOWN9646 E85 COBRA Established Member

    Messages:
    2,167
    Joined:
    Apr 12, 2006
    Location:
    N IL
    Electrical issues suck dd..gl op
     
    Sprayed2v likes this.
  4. hotcobra03

    hotcobra03 Well-Known Member Established Member

    Messages:
    6,591
    Joined:
    Mar 11, 2007
    Location:
    poteet,texas
    I had issues with my brake switch.

    Have you tried with switch off the pedal ?

    There is a tiny plastic bushing on brake pedal.

    Ford only part.

    However mine with bushing I have to push pedal to far to make it work.

    I took it out and it works with finger tip touching pedal
     
    Sprayed2v likes this.

Share This Page