Fuel Hat mount

TT_99Cobra

New Member
Established Member
Joined
Nov 7, 2020
Messages
12
Location
Perrysburg, OH
Hey guys. I think I already know the answer to this but wanted a second opinion. I have a leak at the fuel hat only when the tank is completely full. It comes out around the seal which I have replaced with no change in leakage.

I pulled the tank yesterday and noticed the previous owner seems to have used longer bolts on the fuel hat which protruded through the mounting ring and into the tank. Is this causing my leak?
 

Attachments

  • 262D7B05-D412-4240-BD05-280715B28608.jpeg
    262D7B05-D412-4240-BD05-280715B28608.jpeg
    313.5 KB · Views: 5

TT_99Cobra

New Member
Established Member
Joined
Nov 7, 2020
Messages
12
Location
Perrysburg, OH
Is it tight against the tank with those bolts? Have you checked the other grommets?
It looks tight, but I may have found another issue that may be causing this. The fuel hat is custom made as he decided to go with an external pump that pulled from the top (I feel like this is a bad idea). This is just a flat stock of billet with a couple fittings coming out of it, but looking at the division X hat, there is a lip that goes down in the tank hole that would help seal it. Seems possible that this is my issue more than too long of bolts. Agree?
 

Attachments

  • A84381DE-CDED-4355-8C36-AFBB673DD891.jpeg
    A84381DE-CDED-4355-8C36-AFBB673DD891.jpeg
    292.1 KB · Views: 9

Black02GT

*Not 2KBlackGT
Established Member
Joined
Dec 12, 2004
Messages
5,146
Location
NY
It looks tight, but I may have found another issue that may be causing this. The fuel hat is custom made as he decided to go with an external pump that pulled from the top (I feel like this is a bad idea). This is just a flat stock of billet with a couple fittings coming out of it, but looking at the division X hat, there is a lip that goes down in the tank hole that would help seal it. Seems possible that this is my issue more than too long of bolts. Agree?

Not sure the brand of your's but had the same issue with a very old school Fore hat. All the new style ones have the pumps at a slight angle. Not sure if they were bottoming out or what. I had gotten it used so maybe the previous owner mounted the pumps too low if that's possible. Low story short need much larger pumps and went with a new style hat and had no problems after. What pumps are in there?
 

TT_99Cobra

New Member
Established Member
Joined
Nov 7, 2020
Messages
12
Location
Perrysburg, OH
Not sure the brand of your's but had the same issue with a very old school Fore hat. All the new style ones have the pumps at a slight angle. Not sure if they were bottoming out or what. I had gotten it used so maybe the previous owner mounted the pumps too low if that's possible. Low story short need much larger pumps and went with a new style hat and had no problems after. What pumps are in there?
Mine is a custom made hat that was made to function and look just like the old Fore hats. This one was made to accept an external pump…basically a sump system but from the top instead of the bottom of the tank. I don’t like the set up and it leaks, so I’m going with a Division X dual pump internal setup. I was hoping I didn’t have to buy a new tank because of the longer bolts that were used and punctured into the tank, but I’m thinking that isn’t an issue.
 

Black02GT

*Not 2KBlackGT
Established Member
Joined
Dec 12, 2004
Messages
5,146
Location
NY
Mine is a custom made hat that was made to function and look just like the old Fore hats. This one was made to accept an external pump…basically a sump system but from the top instead of the bottom of the tank. I don’t like the set up and it leaks, so I’m going with a Division X dual pump internal setup. I was hoping I didn’t have to buy a new tank because of the longer bolts that were used and punctured into the tank, but I’m thinking that isn’t an issue.

Sorry unfortunately don't really have an answer. Just passing along my experience. Never followed through, just swapped. Still have the old hat can take pics or ship. Was going deep on e85 so just went a different direction. But I'd start with pump depth.

Took me a while to realize.

Check your flow too. Was getting less than expected as well.

Ford GT Pumps?
Original not the newer ones?
 
Last edited:

Users who are viewing this thread



Top