Ecoboost making some concerning noises

Tyler Quinton

Member
Established Member
Joined
May 24, 2016
Messages
48
So I just recently hit 36,000 miles on my 2018 ecoboost mustang (the end of my warranty) I'm at about 36,600 now. And conveniently after my warranty ended I have a strange squeaking noise that happens when the blowoff valve opens. If I let off throttle and it opens I hear no squealing but it happens when I downshift and occasionally on medium acceleration. I change my oil WAY more frequently than the car suggests (about every 5k) and I always let the car warm up before I drive and cool down before I shut it off. There's no material on the dip stick or in the filter which leads me to believe it's possibly not the turbo. Just curious if anyone else has encountered this or any advice on how to diagnose it because it won't make the noise while the car isn't moving so I can't listen around for the noise while looking at the car. Thanks for any help


Sent from my iPhone using the svtperformance.com mobile app
 

Tyler Quinton

Member
Established Member
Joined
May 24, 2016
Messages
48
The car is bone stock besides a muffler delete and my blowoff valve vents to atmosphere


Sent from my iPhone using svtperformance.com
 

Tyler Quinton

Member
Established Member
Joined
May 24, 2016
Messages
48
That was the next thing on my checklist, just have to get a chance for it to cool down after work


Sent from my iPhone using svtperformance.com
 

Tyler Quinton

Member
Established Member
Joined
May 24, 2016
Messages
48
Maybe i miss understood then cause his 2nd post says his bov vents to the atmosphere

I didn't swap the bov. It's the stock computer actuated bov but I took the recirculation hose off and plugged the hole in the intake tube so I didn't have a vacuum leak. Basically what the vent to atmosphere plate does but doesn't cost $60 lol. More just for fun than anything but turns out when holding speed on the freeway the ecu opens the valve and puts all the hot air straight from the turbo back into the intake and then goes for another ride through the turbo and unhooking it gave a decent bump in mileage so I left it like that


Sent from my iPhone using the svtperformance.com mobile app
 

me32

BEASTLY SHELBY GT500 TVS
Moderator
Premium Member
Joined
Sep 6, 2005
Messages
17,451
Location
CA,NorCal
I didn't swap the bov. It's the stock computer actuated bov but I took the recirculation hose off and plugged the hole in the intake tube so I didn't have a vacuum leak. Basically what the vent to atmosphere plate does but doesn't cost $60 lol. More just for fun than anything but turns out when holding speed on the freeway the ecu opens the valve and puts all the hot air straight from the turbo back into the intake and then goes for another ride through the turbo and unhooking it gave a decent bump in mileage so I left it like that


Sent from my iPhone using the svtperformance.com mobile app

Thanks for explaining that. Well still try setting it back to factory and go from there.
 

nxhappy

Well-Known Member
Established Member
Joined
Dec 16, 2006
Messages
9,959
Location
AZ
I didn't swap the bov. It's the stock computer actuated bov but I took the recirculation hose off and plugged the hole in the intake tube so I didn't have a vacuum leak. Basically what the vent to atmosphere plate does but doesn't cost $60 lol. More just for fun than anything but turns out when holding speed on the freeway the ecu opens the valve and puts all the hot air straight from the turbo back into the intake and then goes for another ride through the turbo and unhooking it gave a decent bump in mileage so I left it like that


Sent from my iPhone using the svtperformance.com mobile app
return it to stock config and see if the noise is gone ...
 

Tyler Quinton

Member
Established Member
Joined
May 24, 2016
Messages
48
I figured if it quiets down or goes away after that then it's the turbo and if not then my only guesses are bearings for one of the accessory pulleys or a throwout bearing/ slave cylinder but pressing the clutch doesn't affect the noise other than the bov closing and the noise goes away. I'll report back in a few, thanks for the help


Sent from my iPhone using svtperformance.com
 

Tyler Quinton

Member
Established Member
Joined
May 24, 2016
Messages
48
So I hooked the bov back up as it came from the factory on Friday and the noise was still there and seemed to be just as loud as before. It seems like it almost got worse since then but I have noticed that I have an exhaust leak where the downpipe mates to the turbo and I'm wondering if this sound I'm hearing is the turbo squeezing its whistle through the gap where it's leaking. Anyone else heard an exhaust leak on an ecoboost?


Sent from my iPhone using svtperformance.com
 

Users who are viewing this thread



Top