• Welcome to SVTPerformance!

Driver Side Seat Won't Go Backwards

Discussion in '2011-2014 Mustang Talk' started by Venom2011GT, Aug 5, 2019.

  1. Venom2011GT

    Venom2011GT Active Member Established Member

    Messages:
    57
    Joined:
    Aug 4, 2018
    Location:
    Memphis
    First, I've tried searching everywhere for a solution but I've yet to find one so I apologize if there is an thread about this subject already...

    I have a 2011 Ford Mustang GT that has under 37,000 miles. The driver side seat will not move back. It is stuck all the way forward. Both driver and passenger side seats are powered by electric motors in which the passenger side works just fine. Every function of the driver side seat works except when trying to move it back. I've already replaced the Power Seat Switch but that did not fix the problem. If someone could point me in the right direction, I'd appreciate it. Also if this thread is in the wrong section, move it please.
     
  2. Norm Peterson

    Norm Peterson Member Established Member

    Messages:
    82
    Joined:
    Jan 1, 2019
    Location:
    on a corner barstool in Boston
    Have you tried sort of throwing yourself backward in the seat while you hold the switch in the "move seat rearward" position? If the seat is stuck for a mechanical reason (including having been run hard up against the full forward position), that might be enough to free it up. Costs nothing to try.


    Norm
     
  3. GN_Mike

    GN_Mike New Member

    Messages:
    5
    Joined:
    Sep 9, 2016
    Location:
    Chicago, IL
    This is a common problem on the 2011’s. In most cases, it’s the motor in the seat. The glue that holds the magnets to the case fails, and the magnets detach. The previous owner of my 2011 had this problem on the passenger seat in my car. I’m praying the drivers side doesn’t fail.

    The official fix is to replace the entire seat mechanism and motor assembly, which is expensive. The unofficial fix is to take the mechanism and motor apart to fix it. There is a video on YouTube referenced in a post on one of the forums that shows how to do this.

    Rule out the easy stuff like the switch or the seat being jammed first. If that doesn’t fix it, it’s likely the motor.

    Good luck,



    Sent from my iPhone using Tapatalk
     

Share This Page