• Welcome to SVTPerformance!

Common issues with the 13's and 14's ?

Discussion in '2011-2014 Mustang Talk' started by CobraG, Aug 30, 2019.

  1. CobraG

    CobraG Active Member Established Member

    Messages:
    2,167
    Joined:
    May 25, 2005
    Location:
    Oklahoma
    I was wondering if any of y'all have had some of the same issues I have with my 2013. And if you have, what did you do to fix it?

    - Vibrating rear view mirror (not due to the stereo), vibrates while driving.
    - Front bumper cover pops loose, after driving the car I have to pop the bumper cover back on, I put my knee against it and pop it back in.
    - The plastic part under the motor is almost completely gone. I've had to cut off/remove parts of it due to it dragging or causing vibrations in the floor.
    - The hose that connects the wind shield reservoir (behind the passenger side tire) broke free, so I used zip ties to hold that in place.
    - Looks like the plastic part for the wheel wells is loose.
    - Bad O2 sensors.
    - Idle bounces up and down (what's that about?)

    I think it's a POS, but my wife really likes it so I guess I'll keep it. It does have some mods that makes it pretty bad a$$ (LT's, X pipe, MagnaPacks, JLT, MGW, Lund Tune, although I have yet to load the tune and I got it back in May). I guess I just need to take the time and MONEY to fix it.
    I bought it used in 2016 with some of the issues, my bad for not checking it out more, that won't happen again. I will own it by the end of this year, so there's that.
    It sits in my building about 95% of the time. When I get near it I get kind of mad due to all the issues. My wife wants me to fix it so I pretty much have an open account for the fixes. Just having a hard time bringing myself to do it.
    Anyone else have anything similar?
    -End Rant
     
  2. Recon

    Recon Well-Known Member Established Member

    Messages:
    2,342
    Joined:
    Jul 23, 2016
    Location:
    In the 427R
    So headers and a cai and you haven’t loaded the tune? Interesting.


    Pick your poison.
     
  3. CobraG

    CobraG Active Member Established Member

    Messages:
    2,167
    Joined:
    May 25, 2005
    Location:
    Oklahoma
    Car didn't come with a handheld when I bought it. I know it must have had a tune, but by who and when I don't know. It's a 2013, I bought it used Oct 2016. It was kind of a knee jerk decision the night I bought it.
     
  4. cheeser

    cheeser Member Established Member

    Messages:
    178
    Joined:
    Sep 28, 2012
    Location:
    CO
    The only issue I had with my 13 was the passenger side visor light staying on...easy fix with replacement visor light assembly from Tasca.

    I do have a persistent P219A code error (bank imbalance) after the VMP supercharger, but working through that.

    Sounds like the previous owner was pretty hard on it.
     
  5. tones_RS3

    tones_RS3 I like members members. Premium Member Established Member

    Messages:
    14,841
    Joined:
    Jan 29, 2016
    Location:
    MA
    I had no issues with my 2013 Mustang.
    Car ran like a top, even though I didn't put many miles on it.
     
  6. SVTXTC

    SVTXTC Active Member Established Member

    Messages:
    843
    Joined:
    Jun 4, 2014
    Location:
    Cincinnati
    AFE21B3E-D12D-4315-8667-513F86AA7D41.jpeg
     
  7. TType85

    TType85 Premium Member Premium Member Established Member

    Messages:
    44
    Joined:
    Feb 17, 2016
    Location:
    Garden Grove, CA
    59K miles on my 13 and i have none of the issues you listed. The only thing I have had is when I take the key out sometimes it keeps beeping like I left the key in until I put the key back in and take it out.
     
    CobraG likes this.
  8. L8APEX

    L8APEX On my tummy..! Established Member

    Messages:
    1,729
    Joined:
    Feb 6, 2007
    Location:
    Wichita, Kansas
    I've had one issue with my '14
    The power window motor was weak/failing on the driver side. Rolling it down It would stop just 1/2 above the top of the weather stripping. Another press and its make it all the way down.
    Got my stang new though.

    Sent from my Note9
     
    CobraG likes this.
  9. Riddick

    Riddick MERICA Established Member

    Messages:
    2,299
    Joined:
    Oct 25, 2012
    Location:
    Haughton, LA
    Most of the issues you listed are common. Mine has 11k miles and the rear view rattles as well as the glove box. I believe they revised the front control arm bushings in late 13, some owners reported squeaking over bumps from the control arms.

    The front bumper clips are garbage, I have had my bumper off a few times and one of the clips broke on the bumper itself, luckily the other one holds it just fine. The splash shield under the car is rather cheap and easily tears. I'm running a tubular radiator support and have it zip tied up. If you ever do a k member you will have to modify it or remove it completely.

    Every Mustang I have ever been in has creaked and rattled a little. As mine gets more miles I'm sure it will follow suit with the rest. I look as it as it's just the nature of the beast. With that said all the stangs have been in have been reliable

    Sent from my Moto Z (2) using Tapatalk
     
    CobraG likes this.
  10. CobraG

    CobraG Active Member Established Member

    Messages:
    2,167
    Joined:
    May 25, 2005
    Location:
    Oklahoma
    Thanks for the replies. I am in the dilemma of either fixing it or just letting it sit in my building. My wife loves the car for some reason, of the 6K miles that have been put on it since Nov 2016 she has probably put around 5K on it. Taking it to Louisiana and back. It sit's at 28K miles now, just low enough I could probably get a decent trade in for it.
    Or, keep it and fix the problems. I'll own it this year, so it's one less car payment. I've had other Mustangs, some had little problems here and there. Never had one with this many problems. I think I feel a little taken by the dealership too, $24K for a car that is falling apart. But, that's my fault for buying it. And it can be fixed, just needs a little TLC.
    Just not sure I want to invest the time and money. When I could just trade it away for a "turn key" car.
    Anyway, thanks again. Nice to have some place to vent, wife gets kind of mad sometimes when I vent to her about the car.
     
    Sabi likes this.
  11. Gruca

    Gruca Active Member Established Member

    Messages:
    503
    Joined:
    Jul 18, 2013
    Location:
    Peotone IL
    My 13 and my 14 both had the rear view mirror issues. Just stick an o-ring between the window and the plastic cover that is right by the window. Cut it and trim the extra length that hangs out, vibration gone.
     
    Riptide, CobraG and kazman like this.
  12. Riptide

    Riptide Well-Known Member Established Member

    Messages:
    1,638
    Joined:
    Dec 23, 2009
    Location:
    Sparks, NV
    My 14 car has had the mirror issue, also solved with the o-ring between the mount and the glass. I also had one of the plastic clips on the front bumper passenger side plastic mounting bracket break last time I pulled the bumper off the car.
     
    CobraG likes this.
  13. arena314

    arena314 New Member

    Messages:
    5
    Joined:
    May 13, 2019
    Location:
    bucks county PA
    my 11' gt has just over 57k now purchased at 49k has been pretty good to me. not a daily but was for about the first 6 months of me owning it. no rattles from the interior whatsoever. I bought it bone stock and have done quite a bit of mods. i have had to replace 2 o2 sensors but that wasnt till after my longtubes were put on and it's a common issue with headers. I wouldnt blame the car for aftermarket part issues. I think my car was pretty much kept in a garage by the first owner then driven a lot on the highway by the 2nd owner and I'm the 3rd. I do get the cold mt82 2nd gear nibble until its warmed up but it sure as hell shifts nice at 7600 rpm lol. your car may have been through a little bit of neglect but sounds like stuff that's fixable and worth it. also ive had sync 1 act up a couple times but not enough to complain about

    Sent from my SM-G965U using the svtperformance.com mobile app
     
    CobraG likes this.
  14. arena314

    arena314 New Member

    Messages:
    5
    Joined:
    May 13, 2019
    Location:
    bucks county PA
    oh and the idle bounce up and down is probably due to the bad o2 sensors. replace o2 sensors and put a tune on it that you know is good

    Sent from my SM-G965U using the svtperformance.com mobile app
     
    CobraG likes this.
  15. CobraG

    CobraG Active Member Established Member

    Messages:
    2,167
    Joined:
    May 25, 2005
    Location:
    Oklahoma
    Thanks for the replies. I need to take mine to get it fixed, I almost did last month, but then forgot. Its one of those out of sight out of mind things. My car sits in a building that I don't go to often, unless we're getting out yard equipment.
    I made a list of things to do, just need to start doing them. I think it's been sitting for 2 months straight now, probably need to at least go start it.
     
  16. califsp

    califsp Member Established Member

    Messages:
    278
    Joined:
    Jan 14, 2008
    Location:
    Albuquerque, NM
    Wow! Not one thing on your list you can't fix yourself. 65000 on my '13 GT and no issues that weren't a quick dyi.
     
  17. CobraG

    CobraG Active Member Established Member

    Messages:
    2,167
    Joined:
    May 25, 2005
    Location:
    Oklahoma
    I don't have the knowledge or desire to fix it myself to be honest. I'd rather just take it to someone and let them fix it.
     
  18. 04sleeper

    04sleeper Runs On "Liquid Gold" Staff Member Super Moderator

    Messages:
    12,377
    Joined:
    Sep 17, 2005
    Location:
    Dallas, TX
    Only issue I have had was the factory cooling fan plug decided to burn up. It's a very common issue after looking it up so fix it now before it leaves you stranded somewhere.
     

Share This Page