• Welcome to SVTPerformance!

2018 F150 compass not working

Discussion in 'F-150' started by Coiled03, Feb 21, 2019.

  1. Coiled03

    Coiled03 Well-Known Member Premium Member Established Member

    Messages:
    12,064
    Joined:
    Jun 25, 2004
    Location:
    IL
    I noticed this morning the in-dash compass on my 2018 F150 isn't working. No matter what direction I'm headed, it says "W". I can't find a reset procedure, anywhere. I think the reason is because it's getting data from the GPS unit, then passing that to the dash display.

    Is there any way to reset it, or do I need to take it in?
     
  2. BlksvtCobra01

    BlksvtCobra01 Deplorable and Proud Established Member

    Messages:
    11,704
    Joined:
    Apr 10, 2008
    Location:
    Ohio
    Try YouTube. I have used numerous help videos on there. If not owners manual. If that fails should be under warranty take it in.


    Sent from my iPhone using Tapatalk
     
    Last edited: Feb 21, 2019
  3. 13COBRA

    13COBRA Resident Ford Dealer Premium Member Established Member

    Messages:
    15,477
    Joined:
    Jun 4, 2012
    Location:
    Missouri
    Start with disconnecting the negative battery cable for 5 minutes, then reconnecting.
     
    me32 and BlksvtCobra01 like this.
  4. Coiled03

    Coiled03 Well-Known Member Premium Member Established Member

    Messages:
    12,064
    Joined:
    Jun 25, 2004
    Location:
    IL
    I mean, if you have a video that would help, you could just post the link here instead of making me search for it. But thanks, I guess?
     
    me32 and 13COBRA like this.
  5. me32

    me32 BEASTLY SHELBY GT500 TVS Moderator

    Messages:
    13,463
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    Yeah exactly
     
  6. BlksvtCobra01

    BlksvtCobra01 Deplorable and Proud Established Member

    Messages:
    11,704
    Joined:
    Apr 10, 2008
    Location:
    Ohio
    I don’t have a video or I would’ve posted it. I’ve found useful helpful automotive tips by searching YouTube. I don’t have a compass issue so I haven’t searched for that.


    Sent from my iPhone using Tapatalk
     
  7. BlksvtCobra01

    BlksvtCobra01 Deplorable and Proud Established Member

    Messages:
    11,704
    Joined:
    Apr 10, 2008
    Location:
    Ohio
    I edited my post which was confusing I’ve used numerous help videos people have posted. I don’t have a YouTube channel for myself.


    Sent from my iPhone using Tapatalk
     
  8. Coiled03

    Coiled03 Well-Known Member Premium Member Established Member

    Messages:
    12,064
    Joined:
    Jun 25, 2004
    Location:
    IL
    For the record, I did absolutely nothing, and when I got in the truck this afternoon, the compass started working again after about 20 seconds.

    This truck is driving me nuts with shit that stops and starts working for no apparent reason. Last week it was one of the BMS sensors stuck on a solid tone.
     
  9. me32

    me32 BEASTLY SHELBY GT500 TVS Moderator

    Messages:
    13,463
    Joined:
    Sep 6, 2005
    Location:
    CA,NorCal
    Do you live in cold weather?
     
  10. BlksvtCobra01

    BlksvtCobra01 Deplorable and Proud Established Member

    Messages:
    11,704
    Joined:
    Apr 10, 2008
    Location:
    Ohio
    My BMS are you referring to back up motion sensors? If so mine do this from time to time. Mostly when it rains then water freezes.


    Sent from my iPhone using Tapatalk
     
  11. Coiled03

    Coiled03 Well-Known Member Premium Member Established Member

    Messages:
    12,064
    Joined:
    Jun 25, 2004
    Location:
    IL
    Yeah, you could say that. I live in IL.

    Yes, the back up motion sensors. I'm pretty sure it froze, like you're talking about. It was a day or two after I went through an automatic car wash to knock the salt off. Probably got some water in there, and it froze.
     
    BlksvtCobra01 likes this.
  12. Zemedici

    Zemedici Well-Known Member Established Member

    Messages:
    19,565
    Joined:
    Jan 7, 2013
    Location:
    Atlanta, GA
    My BMS and BLIS sensors will act up in heavy rain, turning the vehicle off and back on usually fixes it though. Just nature of the beast i guess
     
    BlksvtCobra01 likes this.
  13. BlksvtCobra01

    BlksvtCobra01 Deplorable and Proud Established Member

    Messages:
    11,704
    Joined:
    Apr 10, 2008
    Location:
    Ohio
    Yeah mine normally thaw out pretty quick.


    Sent from my iPhone using Tapatalk
     

Share This Page