01 cobra swap idle issue

cruz1017

New Member
Established Member
Joined
Jul 11, 2018
Messages
11
Location
elkton, maryland
hoping for some help, I swapped an 01 cobra engine and t3650 trans into my 01 gt and I’m having idle issues. It hangs at like 1800-2k a lot of the time, but when I press the brake pedal all the way in it will slightly drop. I’ve replaced the iac valve and gasket and no change. It has a C&L cold air kit on it (which is getting replaced soon bc it’s junk). Just wondering if maybe the brake booster is going out or if I’m over looking something. I’ve checked all vacuum lines and everything seems to be ok. TIA
 

01yellercobra

AKA slo984now
Established Member
Joined
Oct 5, 2005
Messages
18,091
Location
Cali
These cars don't have vacuum brake boosters. It's a hydroboost system that uses the power steering pump for assist. That's why the RPM's drop when you press on the brake pedal. It's loading up the power steering pump.

Are you running the 01 MAF and injectors? If so is the ECU tuned for the new set up? Otherwise it sounds like a big vacuum leak. Was the intake removed during the swap?
 

01vert

Active Member
Established Member
Joined
Mar 23, 2004
Messages
1,261
Location
MA
You replace the IAC with a motorcraft one? Most aftermarket ones work poorly. Cut an IAC restrictor plate and install that to see if it makes a difference.

look for a vacuum leak with carb cleaner or your choice of sprays.

same questions as above
 

cruz1017

New Member
Established Member
Joined
Jul 11, 2018
Messages
11
Location
elkton, maryland
These cars don't have vacuum brake boosters. It's a hydroboost system that uses the power steering pump for assist. That's why the RPM's drop when you press on the brake pedal. It's loading up the power steering pump.

Are you running the 01 MAF and injectors? If so is the ECU tuned for the new set up? Otherwise it sounds like a big vacuum leak. Was the intake removed during the swap?

I bought a handheld sct tuner any recommendations on how or where I can get a decent tune? When I got the swap done I had somebody send me a basic tune just to shut the pats system off so I’m sure it needs tweaked


Sent from my iPhone using the svtperformance.com mobile app
 

CobraSam

Active Member
Established Member
Joined
Apr 26, 2020
Messages
301
Location
Mass
Just a thought to help narrow things down. Where did you source the engine? Was it running correctly before the swap?
 

Users who are viewing this thread



Top